Follow Us on Facebook

Menu
Log in

Historical Construction Equipment Association
Home of the National Construction Equipment Museum


To edit your profile Click Here

1950 D6 9U CATERPILLAR CRAWLER

  • 01/22/2017 11:03 AM
    Message # 4561983

    Need information about the above crawler   trying to get it to start.    Not getting fuel thru the injectors  don't know if its the injector pump or primary pump   the pressure gauge on fuel system never registers any fuel pressure-- I have fuel to the injectors  bled off all lines multiple times there isn't any air in them- fuel transfer pump doesn't read any pressure when turning over the engine.  Have fuel and fluctuates when moving the throttle but not enough pressure to fire the injectors    Wondering if anyone can tell me which pump to tear down first -  have put the injectors into a different engine and they fired -

    Need help  can anybody give some help?  Thanks  Gene Horner   mghorner73@yahoo.com  or cell phone is 2602512278

  • 01/22/2017 5:15 PM
    Reply # 4562479 on 4561983

    Go over to ACMOC web site forums and check there You will find answers to all your questions there

    Chuck C

  • 02/17/2017 10:22 PM
    Reply # 4615665 on 4561983

    the fuel pressure gauge registers the pressure that the primary pump puts up. and i know the engine won't start and run right with low fuel pressure so i would start with the primary pump. check and make sure it isn't sucking air somewhere

  • 03/10/2017 9:17 AM
    Reply # 4659325 on 4561983
    Anonymous

    Don't know if you got the D-6 running or not but if not, you might check your sock fuel filters.  They can get pretty badly filled with algae and dirt if your fuel isn't treated or clean.  You might check your transfer pump also.  Its a gear pump and should be o.k. but never hurts to check.   

Powered by Wild Apricot Membership Software